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1 Preface
1.1 Introduction
Tormach CNC Scanner is a high resolution 2D dimensional scanning system. CNC Scanner includes 3
modules:




Optical centering Module
High Resolution 2D dimensional Scanner
Tormach Scan CAD – 2D drafting and measuring software.

CNC Scanner is designed to be used with a Tormach PCNC or any other machine that uses Artsoft’s
Mach3 PC-based motion control software and an R8, Morse Taper #3, or other ¾” spindle collet.

1.2 The CNC Scanner Concept
CNC Scanner is designed as an affordable measuring and reverse engineering tool to expand the utility
of the PCNC milling machine. It combines an affordable digital USB microscope with simple software
control for analyzing 2D and 2.5D objects.
CNC Scanner can be used for:






Locating work offsets
Accurate measurement of small or difficult-to-measure dimensions
Reverse engineering parts
Simple qualitative metrology
Recreating 2D designs

1.3 Performance Expectations
As with any precision tool, accuracy is a combination of equipment resolution, careful setup, and
technique. With this understanding, we believe the following accuracies are representative of what can
be achieved with the CNC Scanner, although this will vary greatly depending on the details of each
situation.



Optical Centering ±.005” for X and Y positioning
CNC Scanner: ±.001”

1.4 Requirements


CNC Mill controlled by Mach3 (such as Tormach® PCNC or similar)
20 GB Storage Drive (minimum)

Tormach® CNC Scanner
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2 What’s in the Box
2.1 Packing List
Hardware:






USB Microscope
o (Includes Software Driver CD-ROM)
TTS Mount
O-Rings (x2)
Set Screws (x4)
Storage Case

Software:



Tormach CNC Scanner CD-ROM
o (Includes install for both CNC Scanner Plug-ins and Tormach CNC Scan CAD)
Dongle Key
o (if license was purchased)

2.2 Assembling the Scope
To set up the scope:
1. Pull USB cord through the TTS mount
2. Secure the Scope to the mount with O rings
3. Loosely attach the 4 set screws

2.3 Installing the USB Microscope Software Driver
Plug the camera into the computer. Insert the Software driver CD-Rom into the computer and
follow the on screen instructions to install the driver. On some machines the on screen
instructions may not work due to Windows configuration settings. In this case use the Windows
New Hardware Found Screen to install the driver.

UM10138_0712A

10

Tormach® CNC Scanner

Installing CNC Scanner/Tormach Scan CAD

3 Installing CNC Scanner/Tormach Scan CAD
3.1 Running the Set Up Wizard
Follow the directions on the screen to install the
software as shown in Figure 1. This will install both
CNC Scanner and Tormach Scan CAD.

3.2 Using CNC Scanner for the first time
Depending on your specific configuration of Mach3,
you may have configure the CNC Scanner plug-ins
prior to first use. To do so, take the following steps:

Figure 1.

Tormach CNC Scanner Setup

Wizard

1. Start Mach3.
2. Choose ConfigConfig Plugins from the pulldown menu ( Figure 2).

Figure 2. Config Plugins Menu in Mach3

3. Ensure that the plugin topstools is enabled (displays Green Check Mark next to the name). If
a Red X appears instead, click on the box to enable and switch to a Green Check Mark. See
Figure 3.

Figure 3. Enabling the topstools Plug-ins for CNC Scanner and Scope

Tormach® CNC Scanner
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4. Click OK.
5. The CNC Scope and CNC Scan plug-ins should now appear under the Plugin Control menu,
as shown in Figure 4. You may have to restart Mach3 before the new plug-in settings take
effect.

Figure 4. Accessing CNC Scope and CNC Scanner in the Plugin
Control Menu
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4 CNC SCOPE
4.1

Using CNC Scope
To use CNC Scope choose Plugin ControlTormach CNC Scope from the pulldown menu.

4.2 Working with CNC Scope
The CNC Scope window is shown below.

Figure 5. CNC Scope Operators Screen

1. Image Window. Displays the current image of the scope. The center is indicated by the
crosshairs.
2. Close-up Window. Magnified view of current image near the crosshairs
3. Set Axis to Zero. Changes the corresponding X,Y, or Z DRO to a value of “0”. This is
helpful for establishing program reference points.
4. Take Snapshot. Saves the current image as a bitmap (.bmp) file.

Tormach® CNC Scanner
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5.
6.
7.
8.

Camera Settings. Adjusts camera settings (See section 5.4).
Quit. Exits CNC Scope.
Record Scope Setting. You can save up to three scope settings that can be recalled later.
Adjust Crosshair Size. Changes the size of the crosshair circle. This is helpful for centering
over a hole.
9. Pan Crosshairs. Moves Crosshairs with respect to center of image.

4.3 Centering the Scope
If you intend to use CNC Scope as an optical centering device the following procedure is
recommended for the most accurate results.
1. Using the machine, drill a hole in a piece of stock with a good sharp drill bit (a .25 drill bit works
well). Then set the X and Y coordinates to zero.
2. Mount the camera into the camera housing, using the bands provided.
3. Insert the 4 set screws into the 4 locations on the camera housing.
4. Using an Allen wrench, tighten or loosen the screws until the camera appears to be centered in
the camera housing.
5. Mount the camera housing in the machine spindle.
6. Make sure the machine is at the zero coordinate for X and Y, then start the CNC Scope Plug-in
within the Mach 3 control software.
7. Move the Z axis of the machine close to the surface of the material that you drilled a hole into,
and focus the camera using the focus wheel.
8. Using the set screws in the side of the housing adjust the screws in or out to place the red
crosshairs as close to the center of the hole as you can.
9. Using the CNC Scope software, increase or decrease the diameter of the circle on the
crosshairs to closely match the drilled holes diameter.
10. Using your hand slowly rotate the machine spindle while watching the screen. If it appears that
the red circle rotates concentrically around the edge of the drilled hole, then the camera is
centered; otherwise continue to adjust the screws until the circles are concentric.
To test your centering, move the machine away from the drilled hole. Then, by using the machine jog
controls or MDI interface move the crosshairs back over the drilled hole until you think it is over center
and check your X and Y position. If it is close to zero, the scope is centered. If it is not very close, go
back to step 4.
Please be aware that any further focusing or refocusing of the scope after completing the alignment
procedure can have an adverse effect on its performance as an Optical Centering device. For the most
accurate results, the centering procedure should be repeated for each instance.1

1
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5 CNC Scanner
5.1 Before You Begin
Take care in the following preparations. The following recommendations will increase you chance for a
successful scan









Place the object that you wish to scan on a flat surface. A flat plate resting on top of vise works
well. Plate glass works well for small objects.
If possible, place the object on top of a contrasting background. White paper works well.
Make sure the object will remain still and cannot move while the scan is in progress. In general,
this is a problem with lightweight and/or small objects. Larger objects can be held directly in the
vise. Double-sided tape is also helpful. Putty can be used as well.
The scope does not need to be centered for accurate scanning; however, it is helpful if the
scope is rotated within the spindle so the image axes are aligned with the machine axes – that is,
horizontal movement in the image corresponds to X motion of the machine and vertical
movement corresponds to Y motion of the machine.
Ensure the scope is positioned at a safe distance above the object.
Make sure that the complete area that you wish to scan resides within the work envelope of the
machine. If this is not the case, you will trip a limit switch and the scan will be lost.

5.2 Starting a Scan
To start a scan choose Tormach CNC Scan
from the PlugIn Control menu.

5.3 Planning a Scan
When you open CNC Scanner, the Scan Setup
window is displayed as shown in Figure 6.
5.3.1 Naming the Scan File
Type a name for the scan and chose Create
File. The raw scan data is saved in the
directory indicated as: filename.tsi.

Figure 6. Planning the Scan Menu

5.3.2 Determine the Scan Area
Here, you must specify an area to be scanned. Choose a width and depth that defines a rectangular box
around the area of interest (See Figure 7).

Tormach® CNC Scanner
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Depth
(Y Axis)

Width (X Axis)
Figure 7. Determining Width and Depth of Scan area

5.3.3

Choose a desired resolution

Desired resolution is analogous to a ± dimension tolerance in a technical drawing.
Choosing a smaller tolerance will result in a more accurate scan but also results in longer scan times and
larger file sizes. For example, you may choose ±0.001” resolution for a precision mechanical
connection; however, ±0.005” might be okay for recreating a cast surface and ±0.015” might be just fine
for purely aesthetic recreation.
5.3.4

Choose Units

You can choose either Inches or Millimeters. This information will be embedded in the .tsi image.
5.3.5

Pixels / Resolution

This is the minimum number of pixels needed to determine the presence of a feature – for example an
edge. This is used by CNC Scanner during mosaic assembly. The default value is 3.5.
You can experiment with adjusting this value. Increasing this value allows you to increase the working
distance of the camera; however, it will also start to blur edges and reduce the accuracy you can achieve
from measurements in the scan.

UM10138_0712A
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5.3.6

Usable Field of View

The percentage of each photograph used to assemble the mosaic image. A larger percentage results in
faster scan times as the entire image is used for mosaic assembly; if a small percentage is used, the area
between photographs overlaps. See Figure 8. For example, if a 50% field of view is used, the mosaic
will consist of 4x the amount of photographs compared to a 100% field of view; a 10% field of view is
100x. 2

Figure 8. Comparison of 100% FOV vs. 50% FOV

5.4 CNC Scope Camera Settings
Click on the camera icon, shown in Figure 9, to bring up the camera settings screen (Figure 10).

Figure 9.
Camera
Settings Function

5.4.1 Brightness
The overall intensity of reflected light in an image. Lower brightness will be darker and higher
brightness will be lighter.

2

CNC Scanner Design Analysis

Tormach® CNC Scanner

17

UM10138_0712A

CNC Scanner

5.4.2 Contrast
The amount of gradient between the darkest pixels and lightest pixels in the image. Higher contrast will
lighten the lightest pixels and darken the darkest pixels.
5.4.3 Gamma
Signal correction between Scope and Display monitor.
5.4.4 Hue
The distinguishing attribute of color.
This is what makes red different than
blue, for example. When moving this
slider, think about moving around a
color wheel from 180⁰ to -180⁰.
5.4.5 Saturation
The amount of grey in a color. Lower
saturation has more grey, higher
saturation has less grey.
5.4.6 Sharpness
The clarity of detail in an image. Higher
sharpness means more abrupt
transitions between different colors.
5.4.7 Snapshot Size
Options will depend on Hardware.
5.4.8 USB Bandwidth
The rate of data transfer between from
the scope in Mb/s. Choose the highest
rate possible; however, it may be
necessary to reduce bandwidth if you
notice problems with the function of
other USB devices, such as the Tormach
Jog Shuttle. This is dependent on the
performance of the control computer.
5.4.9 Exposure
Total amount of light collected during
image capture. Higher exposure
improves images taken in low light, but
too much can “washout” features.

Figure 10. Camera Settings Menu

5.4.10 White Balance
Adjusts images for the differences in spectral composition of white light originating from different
sources (i.e., LEDS, sunlight, florescent tubes, etc.)

UM10138_0712A
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5.5 Picking a Start Point
The next step is to pick the start point for the scan. This point corresponds to the lower left hand
corner of the image. To do so, simply position the crosshair cursor over the start point of the scan by
moving the X and Y axes of the machine. You can use the arrows shown in the lower left of Figure 11,
or the standard machine controls. When you are over the start point, click “set start point”.

Figure 11. Establishing the Start Point

CNC Scanner assigns the start point a value of (X0.050,
Y0.050). This assures that the area directly around the start
point is included in the scan Figure 12.

Figure 12. Setting the start point for a
scan.
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You can use the arrows on the screen to jog the X and Y axis in discrete step amount specified in the
box. See Figure 13. To use the previously stored start point, choose “Go To Previous Start Point”.

Figure 13. Setting the Start Point

5.6 Establishing Image Scale
After you have selected the Start Point for the image, you must choose a scaling method. Click “Next”
to bring up the three ways to assign a scale for a scanned image, as shown in Figure 14: Use Previous
Scale, Scale by Image, and Scale by Motion.

Figure 14. Choosing a Scaling Method

UM10138_0712A
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5.6.1

Use Previous Scale

This option, shown in Figure 15, reuses the previously defined scale.
The scale will only be correct if the focal plane and magnification has
not been changed from the previous scan. It can be useful for:
 Repeating a scan
 Comparing nearly identical objects; i.e., a series of coins. This
will ensure the scale remains identical in each image.

Figure 15. Use Previous Scale

5.6.2

Scale by Image

You can use a known dimension in the field of view to scale the
scan. This dimension could be, for example:




Ruler
Drilled or, better yet, reamed hole of known diameter
Gauge block

To begin click on the “Scale by Image” icon, Figure 16. This will
bring up the scale by image operators screen (Figure 17). Proceed
as follows:

Figure 16. Scale by Image

1. Scroll the machine to place the small red circle between the 2 scale points you will be using.
Make sure both are visible.
2. Select scale type, linear or circle.
3. Enter your calibration distance and select the appropriate units. (Note: If using scale by circle
enter the diameter, not the radius as the screen says.)
4. Click on “Set First Point” and use the crosshairs to place the first point by clicking on the image.
5. Click on “Set Second Point” and repeat.
6. Click “Next” and then “Start” to start your scan.
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Figure 17. Scale by Image Operator’s Screen

5.6.3

Scale by Motion

A unique feature to CNC Scanner is the ability to scale by motion. With this method, scale is
established by the distance that the machine moves when a distinct point is repositioned from one end
of the field of view to the other end. This point can be:



Machined corners or other geometric features
Dust, pores, grains, scratches, corrosion – any recognizable feature

Scaling by motion will provide improved scaling accuracy of the scanned image when compared to the
traditional scaled by image method. This is because scaling accuracy is determined by the positioning
accuracy of the CNC machine. In the case of the Tormach PCNC, this is better than .001”.
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Figure 18. Calibration Using Scale By Motion

Scale by motion establishes scale by calibrating the change in position of a point in the camera’s FOV
(from 1–› 2) to the actual change in position of the machine (ΔX, ΔY).
The best results are obtained by placing the 1st point in the upper
right of the image and the 2nd point in the lower left as shown in
Figure 18.
To scale a scanned image by motion, choose “Scale by Motion”
(Figure 19). The “Take Snapshot” window will open as shown in
Figure 20.

Figure 19. Scale by Motion

Figure 20. Take Snapshot Window
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Click on “Set 1st Point” and a new camera viewport will open as shown in Figure 21.

Figure 21. Scale By Motion Camera Viewport

The viewport is further broken down into 3 regions
1. The full window is the Field Of View (FOV). This area represents 100% FOV of the camera.
2. Usable Field of View (UFOV) (The darker blue rectangle). This is the area that will be used to
build the photomosaic. This is specified in the planning phase as a percentage of the FOV (See
Section5.3.6). For flat surfaces a field of view of 70% to 90% may work well, for more textured
or curved surfaces a value of 20% may yield better results.

3. Snapshot window (Gray rectangle). To establish scale with the scale by motion technique, CNC
Scanner takes two snapshots. The snapshot window represents the area that will be captured in
each snapshot. You can reposition the snapshot window within the FOV by dragging it with the
mouse.
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When the snapshot window is positioned where you want it, click Take The Snapshot. Now, reposition
by jogging the axes of the machine and repeat to for the second snapshot. To achieve best results,
position the point at opposite corners of each viewport.

Figure 22. Identifying the same point in two frames of reference for Scale by Motion.

With both snapshots taken, the next step is to position the crosshair cursor on the point of interest in
each snapshot viewport. To do so, simply click on the point as shown in Figure 22. When you have
successfully selected the same point in both snapshots, choose “Next” to start the scan.
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Figure 23. Zooming in to identify points with Scale by Motion

You can also zoom in by using the center wheel of the mouse. This allows you to zoom into the
individual pixels of the snapshot to set each point as shown in Figure 23. Press and hold the center
mouse button while moving the mouse to pan the zoomed snapshot within the viewport.

5.7 Completing the Scan
Once you have successfully set the image scale, you are ready to begin the scan. Press “Start the scan”.
CNC Scanner will begin to collect images for constructing the photomosaic. Depending on the number
of pictures needed to build the photomosaic, this process may take some time to complete.
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When the scan is complete, choose one of the following options as shown in Figure 24:




See Scan Result: This will open the image in Tormach® CNC Scan CAD
Do Another Scan: Returns to Plan the Scan screen
Quit: Returns to Mach3 control screen

Regardless of which option you choose, the raw image file is saved as a .tsi in the location chosen during
the Plan the Scan stage.

Figure 24. After completing the scan, the following options are available
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6 Getting Started with Tormach® CNC Scan CAD
6.1 Introduction
This section guides one through the installation of CNC Scan CAD software and explains the basics that
a user needs to know.
NOTE: This guide assumes that you have used other Windows based programs previously and are
familiar with Windows terminology and techniques.

6.2 System requirements
The following operating systems and hardware are recommended to install and run CNC Scan CAD.
6.2.1




Microsoft Embedded Standard : Tormach® Mach OS
Microsoft Windows XP
Microsoft Windows Vista

6.2.2


Operating system

Processor

Pentium III 800 MHz or higher

6.2.3

RAM


6.2.4

Video


6.2.5

1024 x 768 VGA with True Color (minimum)

Hard disk



6.2.6

512 MB (recommended)

3GB minimum for CNC Scan CAD
20GB or greater recommended for CNC Scanner

Pointing device


Mouse, trackball or other devices
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6.3 Installing CNC Scan CAD
The setup program guides you through the CNC Scan CAD installation process. The program will
transfer files to a folder that is created on the hard disk. The program will also create a menu item on
the Start menu.
6.3.1

To install CNC Scan CAD from a compact disc




Insert the CNC Scan CAD compact disc into the CD ROM drive.
Double click the installation file of the desired software on the CD page.
Follow the instructions of the installation prompts to install.

6.4 Help
The help file is accessed by pressing F1 or typing a ? in the command line and pressing enter.

6.5 User Interface
The CNC Scan CAD User interface shown below is loaded when you start CNC Scan CAD. The
interface has a variety of features. Menus and toolbars are located at the top, property and layer
information on the right, and command information on the bottom.
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6.5.1

Menu bar
Use menus and shortcut menus for access to frequently used commands, settings, and modes.

6.5.2

Toolbars
Use buttons on toolbars to start commands, display fly-out toolbars and tooltips.

6.5.3

The Command Bar
The command bar window displays commands, system variables, options, messages, and
prompts. It can be resized as needed.

6.5.3.1

Enter Commands through the Command Line
Commands can also be entered by typing the full command name on the command line and
pressing ENTER or SPACEBAR, or right-click the pointing device to start the command.

6.5.3.2

Cancel Commands
To cancel a command in progress, press ESC.

6.5.3.3

To repeat the last command
Do one of the following:




Press the spacebar.
Press Enter.
Click the right mouse button in the drawing.
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6.6 Command History Window
The text window is a window similar to the command window in which the user can enter commands
and view prompts and messages. A complete command history for the current CNC Scan CAD session
is displayed. To display or close the Command History window Press F2.

6.7 Dynamic input
The dynamic input box, shown in the lower right below, moves with the cursor and displays the
command interface near the cursor. When dynamic cursor is active, you can toggle between input fields
by using TAB.
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6.8 Layer tab
The Layer/Property window is displayed by selecting “Toggle Layer Bar” in the Tool Menu. The layer tab
displays the current layers and their properties.

6.9 Property tab
The property tab displays to properties of each object. You can either select the objects from the pull
down menu or select them by choosing them with the cursor. You can change object geometries by
highlighting their values and entering new values.

6.10 Export tab
The Image and Export Tabs are located below the top toolbar. The Export Tab is used to export the
current CNC Scan CAD drawing as a .DXF file.
Note: In order to execute this command, the hardware dongle must be installed.
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6.11 Image tab
You can use the Image Tab to access the Image functions of CNC Scan CAD. See Chapter 11 for more
details.

6.12 Status bar
You can see drawing mode status at the lower right of the screen by observing which buttons are
depressed on the status bar. These modes are active.

6.12.1.1 Ortho
When Ortho mode is active, you are restricted to drawing only horizontal or vertical lines
6.12.1.2 OSnap
When OSnap mode is active, the active snap modes are toggled on/off
6.12.1.3 Highlight
When Highlight mode is active, objects are highlighted when the cursor is moved over the object.
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7 Working with Drawing Objects
7.1 Selecting Objects
You have a wide range of options when selecting objects for editing. You can create a selection set that
consists of one or more objects before modifying them.
Depending on the type of operation you will be performing you can use one the following methods to
create a selection set:




Choose a command or tool first, and then select objects.
Select objects first, and then choose a command or tool (most objects).
Select objects by pointing, and then use grips to modify them.

7.1.1

Select Objects Individually

You may select one or more objects individually by clicking on them. The selected objects can be
removed from the selection set by holding down the shift key and clicking on them.
7.1.2

Select objects with pickbox

You may select objects using the mouse or other pointing device. The mouse or other pointing device is
represented by a square pickbox on the drawing area. When selecting an object, the cursor square
pickbox should overlap the object. The size of pickbox can be changed on the 'Options' dialog box
found in the Tool Menu or by right clicking on the drawing screen.
7.1.3

Remove Selection from Objects

Press Shift, and then select the entity again (must be running a command).
NOTE Pressing Shift and drawing a window over entities can be used to remove all entities in the
window.
7.1.3.1

To remove all entities from the selection set

Press Escape.
7.1.4

Prevent Objects from Being Selected

You may prevent objects from being selected by using a locking layer. The locking layer means that you
cannot do any operations except for editing objects on this layer.
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7.1.5

Select Objects First

You may select objects first and then choose how to modify them. As one selects each object, it is
highlighted with small squares called grips, which appear at strategic points on the object.
The locations of the grips depend on the type of object selected. For example, grips appear at the
endpoints and midpoint of a line, at the quadrant points and the center point of a circle, and at the
endpoints, midpoint, and center of an arc.

Examples of grip locations for different objects.

After one or more objects are selected, you may choose an object modification command, such as Copy
or Move, from the Modify menu or toolbar.
7.1.6

Select a Command First

After typing a command, the cursor becomes a pickbox and prompts the user to select objects. There
are several methods to select objects:





Select objects using the mouse or other pointing device.
Click on the drawing area and drag the cursor to define a square selection area.
Enter ? to display a list of all selection methods
Use multiple methods together. For example, to select most of the objects on the drawing, you
may select all objects and then remove the undesired ones.

When objects are selected, these objects are added to the selection set. If at least one object is
selected, the removal of one of them is available from the selection set. To finish adding objects to the
selection set, simply press Enter. Most object-modification commands act on the entire selection set.
7.1.7

Object selection methods

When you choose a command that requires selecting an object (such as deleting or changing object
properties, for example), you may use any of the following selection methods by choosing them in the
command line prompt or entering them in the command bar:




Select all entities (ALL) Selects all entities in the current drawing.
Add to set (A) Adds one or more entities to the selection set.
Remove from set (R) Removes one or more entities from the selection set.
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Previous selection (P) Selects entities included in the previous selection set.
Window (W) Selects entities contained entirely within a rectangular selection window.
Crossing window (C) Selects entities contained within or crossing the boundary of a rectangular
selection window.
Window polygon (WP) Selects entities contained entirely within a polygon selection window.
Crossing polygon (CP) Selects entities contained within or crossing the boundary of a polygon
selection window.
Window circle (WC) Selects entities contained entirely within a circular selection window.
Crossing circle (CC) Selects entities contained within or crossing the boundary of a circular
selection window.
Box (B) Selects all entities completely inside a box.
Fence (F) Selects all entities crossing a selection box.
Remove(R) Remove specified entities from the current selection set.
Undo (U) Cancel the last action.
? Displays all selection methods.

7.2 Select Multiple Objects
You can select multiple objects at one time using a rectangular area or fence.
7.2.1

Specify a Rectangular Selection Area

You may select all objects inside the rectangular selection area. When specifying the first corner, there
are two methods to define a rectangular selection window:


Drag the cursor from left to right to create an enclosed window selection. Only the objects
entirely contained in the rectangular selection area are selected, or



Drag the cursor from right to left to create a crossing selection. The objects contained or
passing through the rectangular selection area are selected.

7.2.1.1

To create a Window

1. Click to select a point in the drawing.
2. Click to the right of the first point to select a second point in the drawing.
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Window by selecting the first (A) and second (B) points.

7.2.1.2

To create a Crossing Window

1. Click to select a point in the drawing.
2. Click to the left of the first point to select a second point in the drawing.

Crossing Window by selecting the first (A) and second (B) points

In addition to a rectangular window, you may define a selection window using other shapes such as a
polygon, circle, or fence (a multi-segmented line that selects objects it crosses).
7.2.2

Specify an Irregularly Shaped Selection Area

You may select entities with an irregularly shaped area defined by the specified points. Under the
prompt of SELECT command, you may select entities entirely enclosed by the selection area with
the WPolygon, or the entities enclosed or crossed by the selection area with the CPolygon.
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7.2.2.1

To select objects using Window Polygon

1.
2.
3.
4.

Activate an object modification command.
On the command line, type wpolygon.
Specify the vertices of the polygon.
To complete the selection polygon, press Enter.

Window Polygon by specifying the vertices of the polygon (A, B, and C)

7.2.3

Specify a Selection Fence

It may be much easier to select entities in a complex drawing by using a selection fence. A selection
fence appears like a polyline and chooses only the entities it passes through.
7.2.3.1
1.
2.
3.
4.

To select objects using Fence
Activate an object modification command.
On the command line, type f.
Specify the endpoints of the Fence segments.
To complete the Fence, press Enter.
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Fence by specifying the endpoints of the fence segments (A, B, and C)

7.2.4

Use Other Selection Options

Enter by typing ? This displays all selection options, from which you may choose a proper one.
7.2.5

Remove Selection from Multiple Objects

Under the prompt of Select entities, you may type R and choose a selection to remove objects
from the selection set. You also can enter A to add objects to the selection set.
By holding down SHIFT and selecting objects again, the selected objects will be removed from the
selection set.
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8 File Commands
8.1 Create a New drawing
Command line NEW or File Menu > New to create a new
drawing.
1. File Menu > Open.
2. Choose the folder containing the desired file.
3. Choose the desired drawing and then click Open, or
Double click the drawing.
4. Choose the file type you want to open. CNC Scan
CAD can open .TSP files.

8.2 Save a Drawing
Command line QSAVE or File Menu > Save, This command will overwrite the existing drawing.

8.3 Save As
Command line SAVE or File Menu > Save As to save the file with another name.

8.4 Print
Command line PRINT or File Menu > Print To print the screen or change print settings.

8.5 Exit
Command line QUIT or File Menu > Exit
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9 View Tools
9.1 Redrawing and regenerating a drawing
Command line: REDRAW or View > Redraw
As you work on a drawing, visual elements may remain after the
completion of a command. You may remove these elements by
refreshing, or redrawing, the display.

9.2 Regenerating a drawing
Command line: REGEN or View > Regen
Information about drawing entities is stored in a database as floating point values, ensuring a high level of
precision. Sometimes a drawing must be recalculated, or regenerated, from the floating point database
to convert those values to the appropriate screen coordinates. This occurs automatically. You may also
manually initiate a regeneration. When the drawing is regenerated, it is also redrawn. If more than one
window is displayed, type regenall to regenerate all the windows.

9.3 Magnify a View (Zoom)
Command line ZOOM
You may use ZOOM command to zoom in or zoom out the drawing view. ZOOM does not change the
absolute size of objects in the drawing; it changes only the magnification of the view.
With the zoom feature, you may change the magnification of the drawing at any time. The cursor
changes to a magnifying glass when a zoom tool is active. Zoom out to reduce the magnification so you
can see more of the drawing, or zoom in to increase the magnification so you may see a portion of the
drawing in greater detail.

Tormach® CNC Scanner

41

UM10138_0712A

View Tools

9.3.1

Zooming in and out

One of the easier ways to change the magnification of the drawing is to zoom in or out by a preset
increment. On the Zoom toolbar, the Zoom In tool doubles the current magnification of the drawing.
The Zoom Out tool reduces the magnification of the drawing by half. The portion of the drawing
locating at the center of the current viewport remains centered on the screen as you zoom in and out.

9.3.2

Zooming methods

To zoom, you may use any of the following methods:




9.3.3

Create a window to define the portion of the drawing to zoom
Use a mouse with a wheel and rotate the wheel to zoom in and out.
Zoom to Magnify a Specified Rectangular Area. You may specify a rectangular area
defined by two corners to display the objects within that area as large as desired.

To zoom in to an area using a window
1.
2.
3.

Choose View > Zoom > Window.
Select one corner of the window around the area you want to magnify.
Specify the opposite corner of the window around the area you want to magnify.

To specify a rectangular window around the area you want to magnify, select first one corner (A), and then
select the opposite corner (B)
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9.3.4

To zoom using a mouse with a wheel

Rotate the wheel to zoom in or out. Each rotation of the wheel away from the user zooms out .8
times; each rotation toward the user zooms in 1.25 times.
9.3.5

Displaying the previous view of a drawing

After zooming in or panning to view a portion of the drawing in greater detail, you may want to zoom
back out to see the entire drawing. On the Zoom menu, the Zoom Previous tool allows you to restore
the previous view. Selecting this tool repeatedly steps back through up to 25 successive zoomed or
panned views.
9.3.6

Zooming to a specific scale

You may increase or decrease the magnification of the view by a precise scale factor measured relative
to the overall size of the drawing or in relation to the current display. When you change the
magnification factor, the portion of the drawing located at the center of the current viewport remains
centered on the screen.
To change the magnification of the view relative to the overall size of the drawing, type a number
representing the magnification scale factor. For example, if the user types a scale factor of 2, the drawing
appears at twice its original size. If the user types a magnification factor of .5, the drawing appears at half
its original size.
You may also change the magnification of the drawing relative to its current magnification by adding an x
after the magnification scale factor. For example, if the user types a scale factor of 2x, the drawing
changes to twice its current size. If user types a magnification factor of .5x, the drawing changes to half
its current size.
9.3.7

To zoom to a specific scale relative to the current display
1.

Do one of the following:



2.
3.
9.3.8

On the Zoom Menu > Zoom > Scale, or
Command line ZOOM and then press Enter.

Type the scale factor.
Press Enter.

Displaying the entire drawing

ZOOM Extents displays a view that includes all of the objects in the drawing as large as possible. The
view can display the objects on layers that are turned off but cannot display the objects on frozen layers.
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ZOOM All displays all of objects within either the user-defined limits or the drawing extents, whichever
view is larger.

You may use the Zoom All tool on the zoom toolbar to display an entire drawing.

9.4 Pan a View
Command line: PAN
Use the PAN command to shift the location of the view. PAN does not change the location or
magnification of objects on the drawing; it changes only the view.
9.4.1

Using the Pan command

You may move the drawing in any direction using the pan command. Panning shifts or slides the view of
the drawing horizontally or vertically. The magnification of the drawing remains the same, as does its
orientation in space. Only the portion of the drawing displayed is changed.
To pan, you may use any of the following methods:



9.4.1.1

For precise panning, specify two points defining the magnitude and direction of the pan. The first
point, or the base point, indicates the starting point of the pan. The second point indicates the
amount of pan displacement relative to the first point.
If you have a mouse with a wheel, press and hold the wheel, and then move the mouse.
To pan
1.
2.

9.4.1.2

Choose View > Zoom > Pan.
Specify two points defining the magnitude and direction of the pan.

To pan using a mouse with a wheel

Press and hold the wheel, and then move the mouse in the direction in which one wants to pan.
(The MBUTTONPAN system variable controls this feature.)
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9.5 Toolbar
Command line: SHOWTOOLBAR
This command allows you to toggle the toolbar displays on/off. Choose the either show or hide each
tool bar by clicking on the right hand column.
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10 Modify Tools
You may easily modify the size, shape, and location of objects. Either
enter a command first and then select the objects to modify, or select
the objects first and then enter a command to modify them.

10.1 Undo
Command line UNDO or Modify Menu > Undo
To restore the deleted objects, use the UNDO command.

10.2 Redo
Command line REDO or Modify Menu > Redo
To reverse the UNDO command, use the REDO command

10.3 Delete/Erase Objects

There are 2 methods for removing objects from the drawing:



Delete objects with ERASE command on the drawing toolbar.
Press DELETE to remove a selected objects. (Modify Menu > Delete)

10.4 Copy Objects
Command line COPY or Modify Menu > Copy
Create exact duplicates of objects at a specified distance from the original.
You may copy one or more entities, making one copy or multiple copies within the current drawing.
You may also copy entities between drawings.
You may duplicate objects within the current drawing. The default method is to create a selection set
and then specify a base point, and a displacement point, for the copy.
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Object to copy (A), base point (B), and displacement point (C)

While specifying two points, you can enter two coordinates to define the relative distance you want the
object to move.
10.4.1 Create one copy of an object
1.
2.
3.
4.

Choose Modify > Copy.
Select the objects, and then press Enter.
Specify the base point.
Specify the displacement point.

10.5 Mirror Objects
Command line MIRROR
Flip objects about a specified axis to create a symmetrical mirror image.
You may specify a baseline to create a mirror image using MIRROR command. The mirror image is
symmetrical with the original one. So if one wants to create a symmetrical object, one only need to
draw half of it, and then create the full object using the MIRROR command. When creating mirror
objects using MIRROR command, you must specify a mirror line around which the mirror object is
created.
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10.5.1 To mirror objects
1.
2.
3.
4.
5.

Choose Modify > Mirror.
Select the object, and then press Enter.
Specify the first point of the mirror line.
Specify the second point of the mirror line.
On the command line, if one wants to retain the original objects, type N; if one wants to
delete the original objects, type Y.

10.6 Offset an Object
Command line OFFSET
Offsetting an object creates a new object whose shape parallels the shape of a selected object.
You may use the offset feature to copy selected objects and align the offset to the original objects at a
specified distance. You may make offset objects using arcs, circles, lines.
Making offset copies of curved objects creates larger or smaller curves, depending on which side of the
original object the user places the copy. For example, placing a offset copy of a circle outside the circle
creates a larger concentric circle; positioning the copy inside the circle creates a smaller concentric
circle.
10.6.1 To make a offset copy by specifying the distance
1.
2.
3.
4.
5.

Choose Modify > offset.
Specify the distance by selecting two points or by entering a distance.
Select the object to copy.
Specify on which side of the object to place the parallel copy.
Select another object to copy, or press Enter to complete the command.
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10.7 Move Objects
Command line MOVE
You may move objects to a new place without changing the objects. You may type a coordinate value
for the new position in the dynamic input box. In addition to specifying base point or displacement point
on the drawing, You may also type coordinate value on the command line. The Vector option can also
be used to define a new position.
10.7.1 To move entities
1.
2.
3.
4.

Choose Modify > Move.
Select the objects, and then press Enter.
Specify the base point.
Specify the displacement point.

To move an object, select it (A), and then specify the base point (B) and the displacement point (C)

You may also move objects using grips. To move an object by dragging its grips, select the object to
highlight its grips, and then click the desired grip and drag it to a new position. The grip one selects
depends on the type of object the user is going to move For example, to move a line object, select the
midpoint grip. To move a curved object, such as an arc, circle, or ellipse, select the center point grip.
Not all objects can be moved using grips.
10.7.2 To move an object using grips
1.
2.
3.
4.

Select the object.
Click a grip to select it.
Drag the object to where it needs to be relocated.
Click to release.

10.8 Rotate Objects
Command line ROTATE
Rotate objects around a specified point. You may specify the rotated angle by specifying a point on the
drawing or entering the angle value directly. The direction that objects rotate depends on whether the
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value the user has entered is positive or negative.
10.8.1 Rotate an Object by a Specified Angle
You may rotate objects by specifying a base point or an angle.
10.8.2 To rotate objects
1.
2.
3.
4.

Choose Modify > Rotate.
Select the objects, and then press Enter.
Specify base point.
Specify the rotation angle.

To rotate an object, select the object to rotate (A), and then specify base point (B) and the rotation angle (C)

10.8.3 Rotate an Object to an Absolute Angle
You may also rotate objects by specifying an absolute angle.
10.8.4 To rotate a selection set in reference to an Absolute Angle
1.
2.
3.
4.
5.
6.

Choose Modify > Rotate.
Select the objects, and then press Enter.
Specify base point.
On the command line, type Reference.
Specify the reference angle.
Specify the new angle.

UM10138_0712A

50

Tormach® CNC Scanner

Modify Tools

To rotate an entity in reference to a base angle, select the entity (A), specify base point (B), select the
reference angle and pick point (B) again (or type the @ symbol), specify the second point (C), and then
specify the point representing the new angle (D)

10.9 Scale Objects
Command line SCALE
Resize objects to make them larger or smaller.
You may use SCALE command to zoom the selected objects. You may type a scale factor or specify a
base point and distance to zoom objects. A scale factor that is greater than 1 enlarges the object; and a
scale factor that is smaller than 1 shrinks the object.

You may also scale objects by comparing the basic scale and new scale. The objects become larger if the
new scale is large than the basic scale. The dimensions will be scaled along with the objects.
10.9.1 To scale a selection set by a scale factor
1. Choose Modify > Scale.
2. Select the objects, and then press Enter.
3. Specify the base point.
4. Specify the scale factor.
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To scale an object by a scale factor, select the object (A),and then specify the base point (B) and
the scale factor

10.10 Stretch Objects
Stretch objects using the grab handles.
1.
2.
3.

Choose Modify > Stretch
Click on the object or use a window to select multiple objects
Click on a grab handle and move the cursor to stretch the object

10.11 Trim or Extend Objects
Shorten or lengthen objects to meet the edges of other objects. You may connect edges of objects
through trimming or extending. When trimming or extending objects, you will need to specify cutting
edges to trim or a boundary to extend, then you select objects to cut or extend.
Command line TRIM
You may clip or trim, objects so they end at one or more implied cutting edges defined by other
objects. You may also trim objects to the point at which they would intersect an implied cutting edge.
When trimming objects, one first selects the cutting edges and then specify the objects to trim, selecting
them either one at a time or using the fence selection method.
You may trim arcs, circles, lines, unclosed polylines, and rays. In which, arcs, circles, lines, polylines, rays,
infinite lines, and viewports on a Layout tab can act as cutting edges.

10.11.1
1.
2.
3.
4.

To trim an object

Choose Modify > Trim.
Select one or more cutting edges, and then press Enter.
Select the object to trim.
Select another object to trim, or press Enter to complete the command.
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To trim objects, select the cutting edge (A), and then select the objects to trim (B)

You may trim objects to the nearest point of other objects. By selecting objects and clicking objects to
trim, the system specifies the nearest objects as the cutting edges. The following picture shows that the
crossing boundary is smooth after trimming.

10.12 Extend Objects
Command line: EXTEND
You may extend objects so that they end at a boundary defined by other objects. You may also extend
objects to the point at which they would intersect an implied boundary edge. When extending objects,
you may first select the boundary edges, and then specify the objects to extend by way of selecting them
one by one or using the fence selection method.
You may extend arcs, lines, two-dimensional polylines, and rays. Arcs, circles, ellipses, lines, splines,
polylines, rays, infinite lines, and viewports on a Layout tab can act as boundary edges.

In this example, lines are extended precisely to a circle, which is the boundary edge.
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10.12.1

To extend an object
1.
2.
3.
4.

Choose Modify > Extend.
Select one or more objects as boundary edges, and then press Enter.
Select the object to extend.
Select another object to extend, or press Enter to complete the command.

To extend objects, select the boundary edge (A), and then select the objects to extend (B)
10.12.2

To extend an object to an implied boundary
1.
2.
3.
4.
5.
6.

Choose Modify > Extend.
Select one or more boundary edges, and then press Enter.
On the command line, type edge mode.
On the command line, type extend.
Select the object to extend.
Select another object to extend, or press Enter to complete the command.

Select the boundary edge (A), and then select the objects to extend (B)

10.13 Create Breaks
Command line BREAK
Create a gap in an object, resulting in two objects with a space between them.
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You may break arcs, circles and lines. When breaking entities, you must specify two points for the
break. By default, the point used to select the entity becomes the first break point; however, you may
use the first break point option to select a break point different from the one that selects the entity.

10.13.1

To break an object
1. Choose Modify > Break.
2. Select the object.
3. Specify the second break point.

Select the object (A), and then specify the second break point (B)

10.13.2

To select an object and then specify the two break points
1.
2.
3.
4.
5.

Choose Modify > Break.
Select the object.
On the command line, type first break point.
Specify the first break point.
Specify the second break point.
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Select the object (A), and then specify the first (B) and second (C) break points

TIP: To break an object in two without removing a portion of the object, specify the same point for the
first and second break points by typing the at sign (@) and pressing Enter instead of specifying the
second break point.

10.14 Create Chamfers
Command line: CHAMFER
Chamfering creates a flattened or beveled corner where two lines meet.
You may connect two nonparallel objects by extending or trimming them and then joining them with a
line to create a beveled edge. You may chamfer lines, polylines, rays, and infinite lines. When creating a
chamfer, you may specify how far to trim the objects back from their intersection (distance-distance
method), or may specify the length of the chamfer and the angle it forms along the first object (distanceangle method).
When chamfering a polyline, you may chamfer multiple segments between two selected polyline
segments, or may chamfer the entire polyline.
If two objects to chamfer on the same layer, the chamfer line lies on the layer as the object does;
otherwise, the chamfer line lies on the current layer which controls the properties of the line. The
multiple option can help you chamfer multiple objects at one time.

10.14.1

Chamfer by Specifying Distances
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The chamfer distance is the amount that each entity is trimmed or extended to meet the chamfer line
or to intersect the other. If both chamfer distances are 0, chamfering trims or extends the two entities
until they intersect instead of creating a chamfer line.
The default setting for the first distance is the last one the user has specified, and the second distance is
the same as the first one. However, you may reset the desired chamfer distance.
10.14.2

To chamfer two objects using the distance-distance method
1.
2.
3.
4.
5.
6.

Choose Modify > Chamfer.
On the command line, type D.
Specify the first and second chamfer distances.
Click OK.
Select the first object.
Select the second object.

Select the first (A) and second (B) objects

10.14.3

Trim and Extend Chamfered Objects

If the objects to chamfer are two intersecting lines, and one selects the Trim option to chamfer objects,
the system automatically trims the lines to the endpoint of chamfered line. If the selected lines are not
intersecting with each other, system extends them to get intersection.
If you select No Trim, the system will create chamfer directly and not trim.
Chamfer by Specify Length and Angle
You may chamfer objects by specifying a start point and an angle.
10.14.4

To chamfer two objects using the distance-angle method
1.
2.
3.
4.
5.
6.

Choose Modify > Chamfer.
On the command line, type A.
Specify the chamfer distance and angle.
Click OK.
Select the first object.
Select the second object.
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Select the first (A) and second (B) objects. The chamfer is drawn, based on the distance (C) and the
angle (D)

10.15 Create Fillets
Command line FILLET
Filleting connects two objects with a smoothly fitted arc of a specified radius. You create a fillet using
the FILLET command. This command can apply to objects such as arcs, circles, ellipses, lines, polylines,
radials, splines or construction lines as well as 3D solids.
To fillet two objects
1. Choose Modify > Fillet.
2. On the command line, type R.
3. Specify the fillet radius.
4. Click OK.
5. Select the first object.
6. Select the second object.
When the objects to fillet are on the same layer, the fillet arc is created on that layer; otherwise, the
fillet arc is created on the current layer that affects the properties of objects such as color and linetype.
The Multiple option can create fillets for more than one set of objects until the user exits the command.
10.15.1

Zero Fillet Radius

When the radius is set to 0, the objects to fillet are trimmed or extended to intersect, as opposed to
creating a fillet arc.

UM10138_0712A

58

Tormach® CNC Scanner

Modify Tools

10.15.2

Trim and Extend Filleted Objects

While performing fillet, you may select the Trim option to decide whether the selected edges are
extended to the endpoints of fillet arcs. By default, all objects except for circles, ellipses, closed polylines

With Trim
Option

With No Trim
Option

and splines are trimmed or extended when filleting is performed.
When mode is set to TRIM on the command line, FILLET trims the intersecting lines to the endpoint of
the fillet arc. If the lines do not intersect, the system extends or trims them to get an intersection.
10.15.3

Specify the Location of the Fillet

When the objects to fillet are a line and an arc or a circle, there are several potential fillets and the
system creates the fillet with the endpoint of arc nearest to the selected point. The location of fillets
depends on the objects you specify, as shown in the following picture:

Select objects (A and B)
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11 Image Tools
11.1 Insert a Picture
Command line INSERTIMAGE
You can use this command to insert an image file. CNC Scan CAD can
import the following image types







.tsi
.bmp
.jpg
.tif
.tga
.pcx

11.2 Adjust Angle
Command line BKANG
This command rotates the image around its center by the angular amount specified

11.3 Adjust Angle to Horizontal
Command line BKANG2
This command allows you to rotate an imported image by specifying its horizon. This can be done in
either of two ways:



Choose two points along a straight line
Choose one point and one angle that specify a straight line
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11.4 Crop
Command line BKCROP
This command allows you to crop an imported image by specifying opposite corners of a rectangular
box. Any part of the image that is not contained in the box will be discarded. Cropping should be done
before any other image operations.

11.5 Scale
Command line BKSCALE
With this command, you can change the scale of the image in either the horizontal (X) or vertical (Y)
dimension by drawing a line and reassigning its dimension.
The scaling factors do not need to be the same for both X and Y directions

11.6 Invert Color
Command line BKINV
This command will invert colors of the image, providing a photonegative effect.

11.7 Mirror X
Command line BKMIR
This command will mirror the image in the X direction. The center of the image remains in the same
place.

11.8 Mirror Y
Command line BKFLP
This command will mirror the image in the Y direction. The center of the image remains in the same
place.

11.9 Image Size
Command line BKSIZE
This command is used to resize the image.
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11.10 Information
Command line BKINFO
This command displays information about the image size. You can also adjust the image resolution in
this menu.
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11.11 Color Fade
Command line BKCHROMA
This command is used to fade the image. The native value of an imported image is 100. The image can
be faded from values ranging from100-10, where 10 is the lightest image.

11.12 Image Display On/Off
Command line _IMAGETOGGLE
This command toggles the image display on and off.
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12 Drawing Tools
CNC Scan CAD contains several simple tools
that can be used to trace over images. These
tools can be accessed with using either tool
bar buttons or the Draw pulldown menu.

12.1 Line Tool
Command line LINE
Like most CAD programs, in a simple line with connected segments, each segment is a separate line
object.
A line consists of two points - a start-point and an end-point. You may connect a series of lines, but
once again, each line segment is considered a separate line object.

Start point (A) and endpoint (B).

12.1.1 To draw a line
1.
2.
3.
4.

Choose Draw > Line.
Specify the start point
Specify the end point
Press Enter to complete the command

To start a new line at the endpoint of the last line drawn, start the Line command again and press Enter
at the Specified Start Point prompt.
To continue drawing a line segment from the endpoint of your last line drawing, you may start over with
the Line command, press Enter, and then click your mouse to specify your start-point.
If the last object one drew was an arc, one can also draw a line connecting to and starting from the
endpoint of the arc.
12.1.2 To draw a line as a continuation from the end of an arc
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1.
2.
3.

Choose Draw > Line.
Take the end of an arc as the start point of line.
Specify the length of the line.

Endpoint of previous arc (A) and length of the line (B).

12.2 Arc Tool
Command line ARC
An arc is a portion of a circle. The default method for drawing an arc is to specify three points—the
start point, a second point, and the endpoint. You can draw arcs using any of the following methods:











Three points on an arc
Start point center point endpoint
Start point center point included angle
Start point center point chord length
Start point endpoint included angle
Start point endpoint starting direction
Start point endpoint radius
Center point start point endpoint
Center point start point included angle
Center point start point chord length

12.2.1 Draw Arcs by Specifying Three Points
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Drawing an arc by specifying three points. The start point of the arc (1) snaps to the endpoint of a line. The
second point of the arc (2) snaps to the middle circle in the illustration.

12.2.2 To draw an arc by specifying three points
1.
2.
3.
4.

Choose Draw > Arc
Specify the start point.
Specify a second point.
Specify the endpoint.

Start point (A), second point (B), and endpoint (C)

12.2.3 Draw Arcs by Specifying Start, Center, End
Using command line prompts for drawing arc, draw an arc by specifying center, start point and end
point.

Drawing an arc by specifying three points
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12.2.4 To draw an arc by specifying its start point, center point, and endpoint
1.
2.
3.
4.
5.

Choose Draw > Arc
Press 'C' key to specify the center point.
Specify the center point.
Specify the start point.
Specify the endpoint.

Start point (A), center point (B), and endpoint (C)

12.2.5 Draw Arcs by Specifying Start, Center or End, and Angle
You can draw an arc by specifying start point and included angle. The included angle determines the
endpoint of the arc. Use the Start, End, Angle method when you know both endpoints but cannot snap
to a center point.

1.
2.
3.
4.
5.
6.

Choose Draw > Arc
Specify the start point.
Press 'C' key to specify the center point or ‘E’ to specify the end point.
Specify the center or end point.
Press 'A' key to specify the Specify the angle.
Enter the angle.

Tormach® CNC Scanner

67

UM10138_0712A

Drawing Tools

12.2.6 To draw an arc by specifying two points and an included angle
1.
2.
3.
4.
5.
6.

Choose Draw > Arc
Specify the start point.
Press 'C' key to specify the center point or ‘E’ to specify the end point.
Specify the center or end point.
Press 'A' key to specify the include angle.
Specify included angle.

Start point (A), endpoint (B), and included angle (C)

To draw an arc in a counterclockwise direction, enter a positive value for the included angle. To draw
an arc in a clockwise direction, enter a negative value for the included angle.
12.2.7 Draw Arcs by Specifying Start, Center, Length
Draw an arc by specifying the center of the arc after picking the start point of arc and then specifying
the length of arc. Or use Center, Start, Length, which is actually equivalent to specifying the included
angle.

12.2.8 Draw Arcs by Specifying Start, End, Direction/Radius
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Draw an arc by specifying start, end radius/Direction, and entering a length. You can also click a line
segment using any pointing device either clockwise or counterclockwise. If used the second way, move
the cursor to direct the arc upwards or downwards.

Move the cursor downwards to draw a concave arc or upwards to draw a convex arc.

12.3 Circle Tool
Command line: CIRCLE
You may specify various combinations of center, radius, diameter, points on the circumference, and
points on other objects to draw circles.
The default method for drawing a circle is to specify a center point and the radius.
You may draw circles using any of the following methods:





Center Radius
Two points
Three points
Tangent Radius

12.3.1 To draw a circle by specifying its center and radius
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1.
2.
3.

Choose Draw > Circle>Center, Radius.
Specify the center point.
Specify the radius of the circle.

Center point (A) and radius (B)

12.3.2 Draw a Circle Tangent to Other Objects
A tangent point is a point where an object touches another object without intersecting it. To create a
circle that is tangent to other objects, select the objects and then specify the radius of the circle.
You may also turn on the Object Snap mode to set the snap point as Tangent. This allows circles that
are tangent with other objects can be created easily. A three point tangent method is also available for
creating circles with three tangent points.

The red circle is the one being drawn, and points 1 and 2 select the objects to which it is tangent

12.3.3 To draw a circle tangent to existing objects

Radius of circle (A) and tangent lines (B) and (C)
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1.
2.
3.
4.

Choose Draw > Circle>Tan, Tan, Radius.
Select the first tangent point on the object to be tangent with the circle.
Select the second tangent point on the object to be tangent with the circle.
Specify the radius of the circle.

12.4 Rectangle Tool
Command line: RECTANG
With CNC Scan CAD, rectangles are 4 closed lines. You may draw a rectangle by specifying either two
of its opposite corners.
12.4.1 To draw a rectangle
1.
2.
3.

Choose Draw > Rectangle.
Specify one corner of the rectangle.
Specify the opposite corner of the rectangle.

Specifying opposite corners (A, B) results in the rectangle shown on the right.
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13 Dimension Tools
13.1 Create Horizontal and Vertical Dimensions
Command line: DIMLINEAR
Linear dimensions annotate linear distances or lengths and can be
oriented horizontally, vertically, or aligned parallel to an existing entity or
to the selected extension origin points.
The system automatically applies a horizontal or vertical dimension
depending on the specified extension line origins or the location where
you select an object. However, you may create a dimension by specifying
it to be horizontal or vertical by moving the mouse before placing the
dimension.
13.1.1 To create a horizontal or vertical dimension
1.
2.
3.

Choose Dimensions > Linear.
Press Enter, and then select the entity to dimension. Or, you may insert the dimension
by specifying the first and second extension line origins.
Specify the dimension line location.

13.2 Create Aligned Dimensions
Command line: DIMALIGNED
With aligned dimensions, the dimension line is parallel to the line passing through the extension line
origins. The aligned dimension is also parallel to the objects you specify. The following figure shows two
examples of aligned dimensions. Select the object (1), and then specify the location of the aligned
dimension. The system creates the extension lines automatically.
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13.2.1 To create an aligned dimension
1.
2.
3.

Choose Dimensions > Aligned.
Press Enter, and then select the entity to dimension. Or, you may insert the dimension
by specifying the first and second extension line origins.
Specify the dimension line location.

To insert an aligned dimension by selecting the entity, select the entity (A) to dimension, and then select the dimension
line location (B).

13.3 Dimension Arcs
Command line: DIMANGULAR
Angular dimensions are used to measure the angle between lines or three points. You may dimension
objects including circles, arcs, and lines.
Angular dimension lines are typically represented with arc segments. To create an angular dimension for
two nonparallel lines, the dimension line arc spans the angle between the two lines. As you specify the
dimension line arc location, if the dimension line arc does not intersect one or two extension lines being
dimensioned, the system automatically draws them. The dimension line arc between lines is always less
than 180 degrees. However, for arcs, the dimension of the line arc can be up to 360 degrees.
13.3.1 To dimension an angle between two lines
1.
2.
3.
4.

Choose Dimensions > Angular.
Select one line.
Select the other line.
Specify the dimension line location.
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Select one line (A), select the other line (B), and then specify the dimension line location (C).

If the object to be dimensioned is arc, the dimension line arc is placed between the extensions. The
dimension line arc is also drawn between the extension lines when you use three points to create an
angular dimension. The quadrant of the dimensioned angle depends on the location that you specify for
the dimension line arc.
13.3.2 To dimension an angle encompassed by an arc
1.
2.
3.

Choose Dimensions > Angular
Select the arc.
Specify the dimension arc location.

To dimension the angle subtended by an arc, Select the arc (A), and then specify the dimension arc location
(B).

13.4 Create Radial Dimensions
Command line: DIMRADIUS
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You may create radial dimensions and jogged dimensions for circles or arcs to measure their radius.
You may create radial dimensions for circles or arcs to measure their radius. The radial dimension is a
radial dimension line with an arrowhead that points to a circle or arc.
13.4.1 To create a radial dimension
1. Choose Dimensions > Radius.
2. Select the arc or circle.
3. Specify the dimension line location.

Select the circle (A), and then specify the dimension line location (B).

13.5 Create Diameter Dimensions
Command line: DIMDIAMETER
You may create diameter dimensions for circles or arcs to measure their diameters. Creating diameter
dimensions resembles creating radial dimensions.
13.5.1 To create a diameter dimension
1. Choose Dimensions > Diameter.
2. Select the arc or circle.
3. Specify the dimension line location.
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Select the circle (A), and then specify the dimension line location (B).

13.6 Scale Dimensions
Command line: DIMSCALE
This tool is used to specify the size of the dimension text. The default value is 0.100. Simply specify a
new value to resize the text on new dimensions. Existing dimensions will not be affected.
13.6.1 To resize the scale of the dimension text
1.
2.

Choose Dimensions > Scale
Specify a new value
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14 Tools
14.1 Help
Command line: HELP
Displays the online help menu

14.2 Layer Bar
Command line: ShowLayerCtrl
Toggles the layer bar on/off

14.3 Distance
Command line: DIST
Calculate the distance between any two points you have selected. The following information is displayed:




The distance between the points, measured in drawing units.
The incremental change (delta) in position between the points in both X and Y
The angle made by a line between the two points and the X Axis.

14.3.1 To calculate the distance between two points and their angle
1. Choose Tools > Distance.
2. Specify the first point.
3. Specify the second point.

Use the Distance command to calculate the distance (A) between two points (B and C), the angle in the xy
plane (D), the angle from the xy plane, and the delta x (E), delta y (F), and delta z distances between the
two points.

TIP: To use specific points on selected objects, use object snaps to precisely select the points
on the objects.
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14.4 Object Snap Setting
Command line: OSNAP
Displays Snap menu. You can select active snap points in this menu

14.5 Cursor Options
Command line: CADOPTION
Displays Cursor Options menu.
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14.6 About CNC Scan CAD
Command line: ABOUT
Displays version information

Tormach® CNC Scanner

79

UM10138_0712A

Troubleshooting

15 Troubleshooting
Troubleshooting CNC Scanner
Problem
CNC Scanner Plug-ins
do not appear in Mach3
Menu
Camera does not
display
Camera resolution is
not correct.

UM10138_0712A

Solution
Ensure topstools is
enabled in ConfigConfig
Plugins menu and restart
Mach3
Ensure Camera Software
Driver is correctly
installed
Reinstall camera drivers.
This may also be a
problem with your USB
port. Try another port
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